Note that all SMM websites will disable SSL3 support to prevent attacks based on the POODLE vulnerability as of 10/25/2014. Browsers affected will be IE6, older versions of Safari and IE7/8 on non-updated machines. Please contact support at x237 if your browser is on the list above.

Copyright 2011-2012 Superior Mobile Insurance Solutions
Solutions | Contact

Sorry, an error has occured.

The Page You Are Looking For is Unavailable

Below are some useful links that might help to get you back on the right track, if you feel you have reached this page in error, please contact support@smminsurance.com for more help.

We are sorry for the inconvenience this has caused and hope this has not caused too much trouble.